Jump to content

Ztrem

Members
  • Content count

    329
  • Joined

  • Last visited

About Ztrem

  • Birthday 10/04/1964

Profile Information

  • Gender
    Male
  • Location
    Sea Isle City, NJ

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Ztrem

    Boat Starts Hard After Long Runs

    @gr8lakes-I always wait until the pump stops before starting the engine. @cyclops2-I live at the beach. My lawn is all stone, no grass. @summerpenguin-When I turn the key, there is a beep, but it goes off after 1-2 seconds. Thanks again for taking the time to reply and make suggestions. Kevin
  2. Ztrem

    Boat Starts Hard After Long Runs

    Thanks Cyclops. Good suggestions. I will take a look when the rain stops here in the north east. Been a wet summer.
  3. Ztrem

    Boat Starts Hard After Long Runs

    Thanks for the quick replies. The engine is original from 2003, but heads and manifolds were replaced two years ago. It's a 4.3L MPI Mercruiser, Alpha Gen 1. Boat is 21 feet, no electrical stuff other then lights, radio, and engine components. Battery new, alternator new, starter one year old, impellor new, water pump new, just tuned this year, so plugs, rotor, and distributor new. I don't think it is an electrical issue with the starter. The engine turns over fine, just turns over for longer then normal. Pretty good with maintenance. Boat runs in salt water. I flush the engine with salt-away after every weekend. I did recently post about a gas smell. Still occasionally smell gas. Not sure if from engine or exhaust. Trying to pin point that one. I will try to take a video this weekend. That's a good suggestion. My original post has the information below which I think shows up in all of my posts. I think that covers some of the information requested. I also include the picture on the right to show the layout of the boat. Thanks again for all of your suggestions. I can try opening up the engine compartment while we eat. Easy to do and doesn't cost anything. Kevin 2003 210 SS Ivana Humpalot 4.3L Mercruiser MPI Alpha One Drive
  4. Recently we have been doing some exploring around the back bays of South Jersey. Our trips usually have us running steady for about an hour our two at about 3000'ish RPM, nothing too taxing. We usually end up at a restaurant somewhere, have lunch, then head home. The boat will sit for any where from 1-3 hours while we eat. When I start the boat it turns over for 3-4 seconds, then slowly comes to life. Normally it fires up pretty quickly. It's not a super big issue as I am not worried that the boat will not start, just not sure why this happens and if there is anything I can do to prevent it. I thought about opening the engine compartment while we are eating and letting the engine cool down? Any thoughts appreciated. Kevin
  5. Ztrem

    Depth Indicator Too Sensitive

    Thanks for the comments. Maybe it just needs a good cleaning? Fortunately I have other instruments that read depth, they are just not as convenient.
  6. Ztrem

    Depth Indicator Too Sensitive

    Where is the transducer located and what does it look like? I also have a Garmin GPS and a Fish finder. They both show depth, I just have to stand up to see it. It's nice to have the dash mount.
  7. Ztrem

    Depth Indicator Too Sensitive

    I rarely use my in dash depth indicator any more because it seems overly sensitive. In any kind of turbulent water it cant read the depth and the alarm goes off. In calm water, no problem. I am wondering if there is some kind of an adjustment that can be made to make it less sensitive to the turbulent water? Thanks, Kevin
  8. Ztrem

    Smell Gas When Starting

    Wow. Thanks for all of the suggestions. It only happens when the engine does not start right away. Thats not often. Always run the blower when starting. It's just a habit. Sounds like having a mechanic take a look is the best path forward. Thanks again. Always appreciate the great advice from this forum. Kevin
  9. Ztrem

    Smell Gas When Starting

    I have an MPI engine. Sometimes when the engine does not start right away I will smell gas. I thought it was a closed system so I am not sure why I would smell gas. It does not happen all of the time only when the engine starts hard and turns over for a couple seconds. Any thoughts appreciated. Thanks, Kevin
  10. Ztrem

    When is it time to get a new boat?

    Thank you all for the great and thoughtful comments. Like some of you, the season is short and we want to enjoy every minute. We'll see how it goes. We do love the boat. It's perfect for tooling around the back bays of southern New Jersey. Having all of the vinyl replaced right now. At least she will look good when being towed in .
  11. This is my 10th season with my current boat. For the most part the first 8 seasons did not require any major repairs. Two years ago I had to have the motor pulled twice, new heads and manifolds. Also told the mechanic to replace anything he could see. Last year main shaft in outdrive replaced. Never used sea tow until two years ago. Used it 4 times in the last two years. I am good with maintenance. I flush the engine with salt-away after every weekend. We use our boat a lot. Usually spend every Saturday and Sunday on the water and many weekdays after work during the season. I don't quite have the confidence in the reliability of the boat that I once had. This forum has been very helpful over the years and I am hoping for some good suggestions on when to call it a day and move on to a new boat. We were at the AC Boat show this year and a new boats are pretty expense, although I think a 250 Sun Coast is definitely in my future, just not sure when. Any thoughts are appreciated. Kevin
  12. Ztrem

    Hard Starting Motor

    Thanks Sheppard1. Very helpful. Seems like something I can do. Will also change rotor and cap while I am at it. Don't remember the last time they were replaced. Kevin
  13. Ztrem

    Hard Starting Motor

    I had my engine rebuilt at the end of last season. Working through a few issues. The boat runs better then ever, but I am noticing that it does not start right up when I turn the key. It always used to start up after just a couple turns. Now I have to turn the engine over for several seconds and it slowly comes to life. I am thinking just an adjustment or something like that. I have replaced just about everything on the motor, so not sure what else to look at. All suggestions appreciated. Thanks, Kevin
  14. Ztrem

    Multiple Alarms

    Thanks Shepard1. You are absolutely correct with your suggestion. I was just about to write an update to this post. On Saturday the mechanic hooked the boat up to his computer and we took it for a ride. All looked good except he was getting erratic readings on the water pressure. He put in a new water pressure sensor and that has seemed to fix the issue. I actually went to the parts store to buy the sensor so I know it was the top one with the black fitting. Kevin
  15. Ztrem

    Multiple Alarms

    Thanks for the comments and suggestions. Checked reservoir and it is full. Mechanic headed to boat with tool that reads the alarm codes. Will hook it up and hopefully figure out the source of the alarms.
×