coach

Members
  • Content count

    8
  • Joined

  • Last visited

About coach

Profile Information

  • Gender
    Male
  • Location
    knoxville , tn.
  • Interests
    All sports, boating and music.
  1. Can anyone tell me where I can purchase new canvass tops (2) for my 2008 275 SSI Chaparral ?
  2. Yes, I've done all the "idiot" checks. I have also pushed all the fuse resets but did not check fuse itself (not sure how to actually get to them).Yes, there is a click but nothing else. Thanks for your response and any other advise you might have.
  3. HOW WILL I KNOW IF IT IS OR NOT?
  4. For the last few months when I turn my key to start the engine, there is about a two second delay and then the engine starts. Tried to go out for a ride yesterday. Went to start the engine and it would not turn over at all. When first turn the key, the normal "beep" sounds. All gauges fire up and everything else seems to operate normally. Batteries (2) are both new this year. Can anyone help/advise as to what may be by problem(ignition) ? Thank you
  5. THANKS! I WILL HAVE SERVICE MECHANICS LOOK INTO. MOST LOOK AT ME LIKE I'M CRAZY.
  6. Thank you very much! I will discuss with my service mechanic. It amazes me that none of the mechanics I have spoken with can diagnose my problem
  7. MERCRUISER 8.1 496 MAG BRAVO 3 ON A 2008 CHAPARRAL 275SSI .
  8. I need help...PLEASE ! I have had a problem for two summers that no one seems to be able to fix. I have a 275ssi with only 100 hours on it. Every time I go boating the "engine sensor" light begins flashing when I have been cruising at or above 3000 rpms. Correlating to this is that my trim gauge shows that my trim is moving without me touching it. When I am up and running with my trim up where it should be to prevent plowing or porpoising all of a sudden the "egine sensor" lights on my tach will begin flashing and when I check my trim gauge, it will be in the full down position, having moved on it's own. Can anyone out there ever expeience this and can help me to correct it. I have been to three dealers and no one has solved my issue. I am affraid to even use my boat anymore as the engine sensor lights scare me...THANK YOU!!!