Jump to content

JohnnyV

Members
  • Content Count

    18
  • Joined

  • Last visited

Recent Profile Visitors

1,233 profile views
  1. Sold my 04 265 SSi, big block, now I'm looking for an 07 newer Signature 31, prices are all over the map, I'd prefer Merc over Volvo, V8 only no 6 cyl. Anybody know of any , fresh water & before they go into winter storage? Thanks
  2. I should clarify , I'm speaking of the lower units All engines Volvo or Merc are General Motors ( GM )
  3. I'm Looking at used Fresh Water Signatures and everyone has had twin Volvo's and everyone looks like @#$%@#, peeling paint, corrosion and generally look like crap, While the boat it self is immaculate I've had Merc's 10 years old look almost like new What's up with the Volvo's I thought they were the premier out drive? Why no Bravo 3's on the Signatures ?
  4. Thank you all for your input How do I identify the XDP drive, is there a year (s) that were were most common Anybody prefer Merc Brovo 3's over Volvo ?
  5. Just sold my 04, 265 SSI, Big Block Now looking for either a 2005 or newer 29 or 31 Signature Any opinions out there on which is a better boat ? I saw a really nice 04, 29 with 250 hours, I wish it was newer Should I spend the extra for a 31 ? I appreciate your input Thanks
  6. 320 hours on my 04, 496 Just replaced the IAC this week, only issue so far.
  7. IAC it is, I know I could have replaced it my self but the boat was at the marina & I had them check it out. They said they noticed right away the IAC was cooked, after I told them waht to look for. they hooked to their computer and the code agreed, bad IAC New one installed $ 140.00 for the part $100.00 labor --- ouch but they claim its all fixed We'll find out this weekend Thanks for all of your input & help John
  8. That sounds like it , But the engine still runs fine @ idle Thanks
  9. Thanks Wingnut, After I go back to the dock, I did check, there is water flowing out of the exhaust. Any idea why the alarm is still beeping ?
  10. 2004, 265 SSI, 496, closed cooling, 325 hours, 2nd owner, 3 rd season Spent most of the day on the water, floating or slow crusing 30 mph max for short time In a no wake zone, 1000 rpm for 20 min, 2 beep overheat alarm, kill the engine immediately, open engine hatch see & smell smoke, rubber burining. belt is new & was barely warm, alternator very warm but I think thats normal, I removed the belt, every pully turned easily with no restriction, including alternator. Except the raw water pump.which has a fair amount resistance, I think thats normal. I replaced the belt restarted the
  11. 2004, 265 SSI, 496, closed cooling, 325 hours, 2nd owner, 3 rd season Spent most of the day on the water, floating or slow crusing 30 mph max for short time In a no wake zone, 1000 rpm for 20 min, 2 beep overheat alarm, kill the engine immediately, open engine hatch see & smell smoke, rubber burining. belt is new & was barely warm, alternator very warm but I think thats normal, I removed the belt, every pully turned easily with no restriction, including alternator. Except the raw water pump.which has a fair amount resistance, I think thats normal. I replaced the belt restarted the
  12. It turns out it was a bad battery. Charger output OK, Battery voltage would drop off immediately after disconnecting charger, a couple of dry cells. All is well. Thank you,
  13. I spelled "sulfur" wrong
  14. Has anybody experienced issues with the inverter battery chargers over charging batteries and creating a sulpur odor , or is it more likley I have a bad battery?
×
×
  • Create New...