Jump to content

C'MON 74

Members
  • Content Count

    8
  • Joined

  • Last visited

  1. Ha no kidding about the price of tires.....I recently replaced the tires on my truck, wife's car, and my tandem axle utility trailer, including the spare! That's what I get for waiting until the last minute for it all. The shop did cut me some slack though for buying 13 tires at once!
  2. I found it. It's actually under the motor and looks fun to get to. It appears original to the boat so I think I'll just replace it. Thanks guys!
  3. I'll vouch for Darren at Bent Marine. He knows his stuff and has been in the business for years.
  4. Found it! Thanks! It looks like it'll be fun to get to as well.
  5. I have a '07 190 SSI I just bought last week. During the test run I checked the bilge and I heard it come on. This past weekend we got caught in one of those afternoon thunder showers and the boat got a little water in it. I flipped the bilge switch and nothing happened. I noticed that the light wasn't on the switch so I reset the breaker. Still nothing. First question, where is this thing located? I can't find it anywhere and I suppose it's behind the motor. Has anyone changed it and if so how? Pics would be nice. I'm sure there are some wires exposed since the breaker keeps trippin
  6. I have a '07 190 SSI I just bought last week. During the test run I checked the bilge and I heard it come on. This past weekend we got caught in one of those afternoon thunder showers and the boat got a little water in it. I flipped the bilge switch and nothing happened. I noticed that the light wasn't on the switch so I reset the breaker. Still nothing. First question, where is this thing located? I can't find it anywhere and I suppose it's behind the motor. Has anyone changed it and if so how? Pics would be nice. I'm sure there are some wires exposed since the breaker keeps trippin
×
×
  • Create New...