Cool Change 1

Members
  • Content count

    11
  • Joined

  • Last visited

About Cool Change 1

  1. Here's the update I promised on this. Replaced all four of the battery switches and problem solved. It's very strange they would all fail at once. It's almost like someone deliberately sabotaged them. Thanks for everyone's input! Much appreciated.
  2. I think the issue is with the battery selector switches. They're hot on the input side and nothing out. I though it was kind odd when I first turned them on. There was absolutely no tension in them. Good advice Phillbo and they are and do. I'll change out the switches next Wednesday or Thursday and report to the crowd. That's got to be it right? By the way I love the TJ quote. Couldn't agree more. Tax the rich (not that I'm rich) and feed the poor doesn't work.
  3. I think the issue is with the battery selector switches. They're hot on the input side and nothing out. I though it was kind of odd when I first turned them on. There was absolutely no tension in them. They just kind of spin freely. Can anyone comment on that?
  4. No Richard and yes I am an idiot. I had my family with me today and it was a total cluster. I just find it hard to believe that all the batteries are dead except the house battery. It's been a well kept boat and the battery switches and all breakers were switched off when I boarded. Something weird here.
  5. Just took delivery on my new (to me) 2006 Signature 350 today. I purchased it in Florida and had it hauled to Table Rock Lake in Missouri. We wet launched her and as she floated off of the trailer I had absolutely no power to the engines. The boat was surveyed and sea trialed and passed with flying colors. It's equipped with the three battery arrangement with port, starboard, and house batteries. I switched on both the port and starboard batteries and nothing. After several hours of (had to tow to my slip) hooked up to shore power with battery charger on, still nothing. No blower, no instruments, no outdrive trim. Zip.The toggle switch at the helm is switched to the run position. I feel like I'm missing something here. Any help greatly appreciated.
  6. Just took delivery on my new (to me) 2006 Signature 350 today. I purchased it in Florida and had it hauled to Table Rock Lake in Missouri. We wet launched her and as she floated off of the trailer I had absolutely no power to the engines. The boat was surveyed and sea trialed and passed with flying colors. It's equipped with the three battery arrangement with port, starboard, and house batteries. I switched on both the port and starboard batteries and nothing. After several hours of (had to tow to my slip) hooked up to shore power with battery charger on, still nothing. No blower, no instruments, no outdrive trim. Zip.The toggle switch at the helm is switched to the run position. I feel like I'm missing something here. Any help greatly appreciated.
  7. Just took delivery on my new (to me) 2006 Signature 350 today. I purchased it in Florida and had it hauled to Table Rock Lake in Missouri. We wet launched her and as she floated off of the trailer I had absolutely no power to the engines. The boat was surveyed and sea trialed and passed with flying colors. It's equipped with the three battery arrangement with port, starboard, and house batteries. I switched on both the port and starboard batteries and nothing. After several hours of (had to tow to my slip) hooked up to shore power with battery charger on, still nothing. No blower, no instruments, no outdrive trim. Zip.The toggle switch at the helm is switched to the run position. I feel like I'm missing something here. Any help greatly appreciated.
  8. I just purchased a 2006 Signature 350. Going to base at Port of Kimberling Marina for the balance of this year and next year through mid July (at least). It looks like The Harbors is the Chaparral/Volvo Penta authorized service on the lake. Does anyone have any observations/suggestions on finding a go to for service? Is it the Harbors? Thanks
  9. I just purchased a 2006 Signature 350. Going to base at Port of Kimberling Marina for the balance of this year and next year through mid July (at least). It looks like The Harbors is the Chaparral/Volvo Penta authorized service on the lake. Does anyone have any observations/suggestions on finding a go to for service? Is it the Harbors? Thanks
  10. Thanks guys. Mounting on the rail sounds like it would be much simpler.
  11. I just purchased a 2006 Signature 350. I'm looking for the pedestal mount grille that Chaparral offers as an option. Does anyone have any info on that?