Jump to content

sconley7942

Members
  • Content count

    31
  • Joined

  • Last visited

About sconley7942

  • Birthday August 17

Profile Information

  • Gender
    Male

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. sconley7942

    Low rpms? Prop?, Engine problem?

    Thank you all for holding my hand though my self inflicted conflict. I checked the wiring twice before installing the motor and can't count how many small block tune ups I have done.
  2. sconley7942

    Low rpms? Prop?, Engine problem?

    I found the problem I am an idiot. When I ran the plug wires I swapped #7 and #8 I pulled the plugs and those 2 we're clean, traced the wires and there it was, I did check the flappers they are fine. We dropped her in the river and I got it up to 4k rpms and 40 mph on a very rough river 12 mph north west winds, gonna order a new prop I think it will correct the rest
  3. sconley7942

    Low rpms? Prop?, Engine problem?

    I just got back to the house, I am going to pull the plugs and also check the exhaust flappers, I will see if I can grab a fuel pressure gauge from work and check it one day this week
  4. sconley7942

    Low rpms? Prop?, Engine problem?

    How can I check the anti siphon valve, and the exhaust flappers. I am not sure why the previous engine blew. Was just told it hydro locked
  5. sconley7942

    Low rpms? Prop?, Engine problem?

    The choke is fixed, I was able to watch the secondaries open. I will pull the plugs and check them.
  6. sconley7942

    Low rpms? Prop?, Engine problem?

    I am stilled stumped, timing is advancing properly, I got the choke working, secondaries are opening, still only 3400 rpms and 32mph. I guess I will try a new prop?? engine runs great just lacks in power
  7. sconley7942

    Low rpms? Prop?, Engine problem?

    I got out of work early today (on time) and it wasn't raining so I got a look at it. The timing is advancing properly and the base timing is dead on 8*, I think the choke is not fully coming off, therefore it will not let the secondary's open, it does have mechanical secondary's. I ran out of time and daylight. the carb is electric choke and there is no power on the + wire. I am not sure how the choke works. I am real familiar with fuel injection, carbs drive me bonkers
  8. sconley7942

    What prop should I run, so confusing

    17 3 blade or 4 blade I was reading the 4 blades are better with hole shot
  9. sconley7942

    What prop should I run, so confusing

    I will take the hatch off and leave it at home
  10. sconley7942

    What prop should I run, so confusing

    It's the original one, I am sure it's a marine unit, it has no mechanical linkage so I am sure it is vacuum operated, it doesn't have a vacuum hose to it though
  11. sconley7942

    What prop should I run, so confusing

    I was thinking about a 4 blade 19p, do you think a 3 blade of a different pitch would be better?
  12. sconley7942

    What prop should I run, so confusing

    No, I didn't think to look, that is on my to do list. This is my first boat I am learning. If they are not opening what can cause that?
  13. sconley7942

    What prop should I run, so confusing

    At wot it's only at 3500 rpms
  14. sconley7942

    What prop should I run, so confusing

    It's an alpha one
  15. sconley7942

    What prop should I run, so confusing

    It's a Carter 4 barrel, vacuum secondaries, choke is opening. It runs great just no power
×