Jump to content

Search the Community

Showing results for tags 'lower unit'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Contests!!
    • Contests!!
    • Polls!!
  • Chaparral Boats Forum
    • Boat Talk
    • Dock Talk
    • Newbies
    • Info Center
  • Regional Forums
    • Midwest U.S.
    • Northeast U.S.
    • South Central U.S.
    • Southeastern U.S.
    • West Coast U.S.
    • Northwest U.S.
    • Rocky Mountain Region U.S.
    • Eastern Canada
    • Western Canada
    • International Boating
  • Suggestions & Comments
    • Site Suggestions & Comments
  • Gulf Coast

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 3 results

  1. Hello I just bought a chaparral 178 from a guy that hasn't ran it in a year. I knew the boat would need some work and this is my first boat and It seems to be a little different from a car, I know basic stuff like the engine oil, spark plugs, and battery need to be replaced but what about other stuff like alternator and carburetor. What do I need to do to get it running. Any help would be greatly appreciated. And the engine is a 140 hp 180 displacement 3.0 liter 4 cylinder mercruiser. And also I was watching a video on how to change the lower unit gear oil but there is no bolt near the prop to
  2. I have a 1999 Signature 240, 5.0, alpha 1. Didnt have an alarm prior to the impeller change. Now I have the most awful constant alarm imaginable. Reservoir for lower unit oil wasn't at first start up because I forgot to check it. I filled it up and tried again with the same alarm. What am I missing and how do I get rid of this noise??
  3. The lower unit will not go down. I hear a clicking noise when I press the down button. Any suggestions?
×
×
  • Create New...