Jump to content

Search the Community

Showing results for tags 'mercruiser 4.3'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Contests!!
    • Contests!!
    • Polls!!
  • Chaparral Boats Forum
    • Boat Talk
    • Dock Talk
    • Newbies
    • Info Center
  • Regional Forums
    • Midwest U.S.
    • Northeast U.S.
    • South Central U.S.
    • Southeastern U.S.
    • West Coast U.S.
    • Northwest U.S.
    • Rocky Mountain Region U.S.
    • Eastern Canada
    • Western Canada
    • International Boating
  • Suggestions & Comments
    • Site Suggestions & Comments
  • Gulf Coast

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 3 results

  1. Impulse purchases. Some buy candy bars or lottery tickets, I'm buying a boat. I'm new to the boating world, and will appreciate the wisdom and information of this forum. That said, here's the boat story: A few weeks ago, I saw a 1994 Chaparral 1830 SST Sport with a 4.3L l6 MerCruiser in my friend's yard and said: "ooh, who's boat?" The response was jokingly "wanna buy it?" And then I thought about it. And that was a mistake. Unfortunately, my response due to my "thinking" was not: "haha, nooo- I have way too many protects already." It was instead: "how much?" Long story sho
  2. I have a 4.3L mercruiser alpha engine and have had a leak on the drive oil. I need to top it up but I'm not sure if it has had a the high performance quicksilver or the premium quicksilver gear oil in it. How can you tell the difference? Thanks, Jamie
  3. I have twin Mercruiser 4.3 and and all of a sudden the starboard engine is running at higher rpms than the port engine. At full throttle I'm getting about 4800 rpm on the starboard and 4100 on the port engine. I'm curious what would cause this, both engines seem to be running well and I don't feel a lot of pull on the starboard side, in fact my sync gauge shows that the port engine is pulling a little stronger. Thoughts?
×
×
  • Create New...