Jump to content

Search the Community

Showing results for tags 'trim sender'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Contests!!
    • Contests!!
    • Polls!!
  • Chaparral Boats Forum
    • Boat Talk
    • Dock Talk
    • Newbies
    • Info Center
  • Regional Forums
    • Midwest U.S.
    • Northeast U.S.
    • South Central U.S.
    • Southeastern U.S.
    • West Coast U.S.
    • Northwest U.S.
    • Rocky Mountain Region U.S.
    • Eastern Canada
    • Western Canada
    • International Boating
  • Suggestions & Comments
    • Site Suggestions & Comments
  • Gulf Coast

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. I encountered an issue on my 2014 31 Signature early this season. When I put the boat in the water in April, the trim gauge for the starboard engine wasn't working. Within two weeks the starboard Bravo Three drive was stuck in the down position. Luckily the boat was still covered by the extended Brunswick warrant, but Covid was running wild in NY state. My local marina was closed by government order. I contacted Brunswick and explained the situation, they were very understanding. I was asked to document the issue in writing, and contact them when the work was going to be performed. My war
×
×
  • Create New...