Jump to content

Search the Community

Showing results for tags 'Mercrusier Power Trim'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Contests!!
    • Contests!!
    • Polls!!
  • Chaparral Boats Forum
    • Boat Talk
    • Dock Talk
    • Newbies
    • Info Center
  • Regional Forums
    • Midwest U.S.
    • Northeast U.S.
    • South Central U.S.
    • Southeastern U.S.
    • West Coast U.S.
    • Northwest U.S.
    • Rocky Mountain Region U.S.
    • Eastern Canada
    • Western Canada
    • International Boating
  • Suggestions & Comments
    • Site Suggestions & Comments
  • Gulf Coast

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 2 results

  1. This past Saturday I bought a new 2015 H2O Sport. Test run with dealer went just fine, walk through everything looked good. Brought her home, gave her a good cleaning and went to put put her in the garage...power trim will not lower unit. Called the dealer, talked to "Tom" in the service department, tried a few things..nothing worked. He told me, "someone ran the unit up to far" ????? I'm taking it back to the dealer in the morning! So far, not what I expected....
  2. This past Saturday I bought a new 2015 H2O Sport. Test run with dealer went just fine, walk through everything looked good. Brought her home, gave her a good cleaning and went to put put her in the garage...power trim will not lower unit. Called the dealer, talked to "Tom" in the service department, tried a few things..nothing worked. He told me, "someone ran the unit up to far" ????? I'm taking it back to the dealer in the morning! So far, not what I expected....
×
×
  • Create New...