Jump to content

Search the Community

Showing results for tags 'repairs'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Contests!!
    • Contests!!
    • Polls!!
  • Chaparral Boats Forum
    • Boat Talk
    • Dock Talk
    • Newbies
    • Info Center
  • Regional Forums
    • Midwest U.S.
    • Northeast U.S.
    • South Central U.S.
    • Southeastern U.S.
    • West Coast U.S.
    • Northwest U.S.
    • Rocky Mountain Region U.S.
    • Eastern Canada
    • Western Canada
    • International Boating
  • Suggestions & Comments
    • Site Suggestions & Comments
  • Gulf Coast

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 4 results

  1. Hello fellow Chap owners. So I brought my 1995 Signature 27 in for it's yearly maintenance and I was very specific about inspecting the cooling system. My mechanic said they inspected it and found no problems but from looking at the picture you can see that's obviously not the case, you don't have to be an expert to see this and know there is a problem. Yesterday while I was out cruising the hose clamp broke which caused the engine to suddenly loose all of it's coolant and severely overheat while I was at 3000 rpm.(fyi: the "maintenance" was done just 1 week ago) The temperature gauge was topped out. As soon as I noticed the problem I shut down the engine but I'm not sure how long it ran before I noticed it. I normally monitor the gauges and I do remember seeing the temp was normal right before bringing the boat up to plane. The next thing I know the engine was overheating. Now I'm wondering what damage was done before I shut it down. Once it cooled down it did start right up but was making a squeaking sound and did heat right back up so I shut it down again and got towed, I'm hoping that was just the belt squealing. Of course this never should of happened if they were doing their job in the first place but that's a post for legal. Any ideas as to what tests I should run besides compression? What damage to look for? I plan on hiring a third party to inspect and test the engine. Thanks I
  2. I have read many of your great responses and I figured I would introduce myself. I am Steve and I have just purchased a one owner 1985 Chaparral 238 XLC. The catch is it has been resting since 2000. I found it to be in pretty good condition for the amount of time it has been resting. It has the 230 Mercruiser with the alpha 1 best I can tell with the high-fire ignition. it was shrunk wrapped and in mostly good condition with some sun fade where the belly bands had allowed the shrink wrap to ride up. The first few things that I have noticed right away was the bellows were falling out of it, a through hull for the sink was broken. I brought it home and have been trying to figure out where to start first after loading the boat by myself onto the trailer with nothing but a jack and stack of wood. I figure there are a number of things I would replace such as the bellows, water pump, lower unit oil, engine oil, shift cable, Gas, and the battery. I think that there should be a number of other things that I should worry about as well and that is where I am hoping to find out from your experience! I know that the window seals are shrunk, and they will need to be replaced, but I figured I should get it running first. although my concern is that there is some water right at the base of the steps while it is just sitting on the trailer. I have seen some similar posts but I don't see a floor drain right there in plain view is there something under the carpet? can I buy the window seals for this? Where do you guys get your parts reasonably? Finally, If you have part numbers for Bellow kit, shift cable kit, water pump kit, and any other advice would be welcome. Regards Steve
  3. Noonan1

    Warning light

    I was on the water today in my 2013 SSI 226 and got an audible alarm and a dash indicator that said something like “inadequate power to the engine.” I throttled down and got it back to my dock. When I lifted it out of the water, water spilled out of the bilge. I have never had anything like that happen. The water may have been from the fact that I washed the boat yesterday, but I don’t think so because I pumped the bilge when I was done cleaning. Any ideas?
  4. Our 2004 Chaparral 290 Signature is undergoing surgery! The fuel tank has to be replaced due to a persistent leak identified last October. Fiberglass workers have already removed the Aft cabin floor to expose the tank (and ventilate). Talks now indicate that further cuts will be necessary to get the tank out. They are proposing to remove the bulkhead in the engine compartment (mid cockpit) in order to be able to maneuver the tank out but at additional cost and time and obvious surface area intrusion. So the question to the forum is,: 1) Does this seem extreme for those who have been successful with replacing a leaking fuel tank? 2) Has Chaparral provided any guidance for the task that was helpful? We plan to reach out tomorrow to headquarters. 3) Has insurance covered the extensive work required? At this point they are balking and challenging to whether we just total the boat and receive a check. Appreciate any relevant replies and personal experience to shed light on our challenges. Thanks
×
×
  • Create New...