Jump to content

Search the Community

Showing results for tags 'stall idle oil fuel gas'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Contests!!
    • Contests!!
    • Polls!!
  • Chaparral Boats Forum
    • Boat Talk
    • Dock Talk
    • Newbies
    • Info Center
  • Regional Forums
    • Midwest U.S.
    • Northeast U.S.
    • South Central U.S.
    • Southeastern U.S.
    • West Coast U.S.
    • Northwest U.S.
    • Rocky Mountain Region U.S.
    • Eastern Canada
    • Western Canada
    • International Boating
  • Suggestions & Comments
    • Site Suggestions & Comments
  • Gulf Coast

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. Hi all, Lately I’ve noticed poor acceleration and the oil pressure drops to almost 0. The oil is a bit on the high mark on the dipstick. I removed the fuel pumps and cleaned out their screens. They were filthy. I also dumped the contents of the fuel filter water separator. There was some water in there. I pulled the fuel tank pickup tube and the fittings and tube itself look great. It did not have a screen on it. other than idling sometimes and pulling skiers around the boat runs smoothly and is powerful. so you know what’s going on? Any advice or has this happened to anyone else? Thanks. Jay
×
×
  • Create New...