Search the Community

Showing results for tags 'windlass'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Contests!!
    • Contests!!
    • Polls!!
  • Chaparral Boats Forum
    • Boat Talk
    • Dock Talk
    • Newbies
    • Info Center
  • Regional Forums
    • Midwest U.S.
    • Northeast U.S.
    • South Central U.S.
    • Southeastern U.S.
    • West Coast U.S.
    • Northwest U.S.
    • Rocky Mountain Region U.S.
    • Eastern Canada
    • Western Canada
    • International Boating
  • Suggestions & Comments
    • Site Suggestions & Comments
  • Gulf Coast

Calendars

  • Community Calendar

Found 11 results

  1. Hi, I recently bought a 2006 Signature 240 and I'm loving it!!! I often tie up with friends, and sometimes I'm on the boat by myself, making it hard to steer, put out fenders, run to the bow to drop anchor and also tie up all at once. I can't count on my friends to do much, as they are sometimes in the water when I arrive. A windlass seems like a great idea. Any suggestions for brands, models and installation tips? I'd also love to connect with other Sig 240 owners to share info and tips. Looking forward to hearing from you. Thanks!!
  2. The windlass on my 2001 Chaparral Sig 300 was having issues getting hung up frequently when lowering or raising the anchor. Now the windlass motor will only retract the anchor back up, but the windlass does not drop the anchor. When I hit the down button on the switch, you can hear the motor running but the chain/rope does not move to lower the anchor. I was messing with the windlass and rotating the right side that you can only turn one direct on the windlass, to see what that does. Does anyone know if rotating this disc on the windlass disengages the windlass or how to get the windlass to lower the rope/chain? Thank you.
  3. Wondering if anybody has successfully added an anchor winch on to their sunseta? I've a sunseta 224, and I'm wondering how to add a winch on to it, since pulling it when i'm out with kids proves too much of a hassle!
  4. Hello y'all, tried to drop anchor and windlass was inoperable. I replaced the 2 foot switches that were old and dried up. Today, I pushed on the windlass button and the breaker popped. Does anybody have encountered similar issue? i'm thinking solenoid? Thank you all as always
  5. Hi out there! I have a 2005 290 Signature. Can anyone tell me the size of the anchor rope and chain that was supplied by Chaparral? I am looking to replace the setup and can't find it called out in any of my documentation. I have a vertical windlass, original to the boat, and the manual calls for several different sizes according to the spool number. I have not been able to find a number on the spool. Thanks in advance for your help.
  6. Have 2001 Chaparral Signature 300. Windlass works intermittently via foot switches. Want to check/clean solenoid before replacing switches. Any ideas where it is located? Has anyone else had same issue and repaired without replacing parts?
  7. I am working on a project of installing an anchor windlass on my 205. I already have the windlass assembly which I intend on mounting inside the anchor locker. But, the system I have is more or less for deck mounting, especially the windlass retrieval bracket. I would like to make that a thru-hull unit like that pictured below. Is this part available from somewhere? This or even a smaller one? Any ideas appreciated! Thanks!!
  8. Before posting, I searched the forum for windlass posts and read all I thought pertained. I did not see info on my questions, but if it's there and I missed it, apologies in advance. I'm replacing my original 2004, sig 350 Horizon windlass with the Lewmar Pro Seies 1000h as mine finally died and parts I'd need are not available. I'm looking for some pre-project information even though I've scheduled a professional marine electrician for a couple of weeks from now. Question #1 is I pulled the original manual and its a combo booklet for the Horizon 600 & 900 models. It shows where the serial # and model should be but there is nothing. Maybe a long since lost sticker so if anyone knows, I'm looking for confirmation that the unit that would have been installed on sig 350's in 2004 is the 900? Question #2 is the new windlass came with a 70 amp breaker. I will likely need to use this, but it will require creative install due to different style from original. Does anyone know the amp rating of the original breaker that's in the battery switch cabinet? I'm thinking its a 50, but the original booklet lists 50 and 70, so maybe I'll be able to use what's there. Last question, I looked inside the anchor locker on the bulkhead and see some terminals on a block with some large (about battery cable size) wires on it. I'm guessing this is the contactor box, but looks like the windlass motor wires go inside and perhaps attach on the cabin side of the bulkhead? I'm wondering if anyone knows for sure where the windlass motor wires mount to the control box and also what we'll need to remove inside in order to access....bulkhead mirror, vinyl trim board above mirror, etc. Thanks in advance! Mark
  9. I recently bought a Lewmar Pro-Series H700 only to find out it doesn't fit the locker. To fit, the locker needs to be modified for the winch and I don't want to get in to this. Has anyone bought an electric windlass for a 2001 285 SSi that fits. Thanks for your support. Ihab
  10. I recently bought a Lewmar Pro-Series H700 only to find out it doesn't fit the locker. To fit, the locker needs to be modified for the winch and I don't want to get in to this. Has anyone bought an electric windlass for a 2001 285 SSi that fits. Thanks for your support. Ihab
  11. HI I"m new to this great forum and to my 2004 Sig 290. While I briefly and successfully tested the foot switches for my windless during my sea trial and survey a few months ago, yesterday out on San Diego Bay neither my helm rocker switch or my foot controls near the locker worked. I'm embarrassed to say that I could not find the breaker for my windlass. Now that I remember it must be a high current circuit I'm hoping someone can tell me where the breaker is? Looking in the aft battery selector/breaker panel I could not find it but I was looking for low curret DC breakers only. Does anyone know where I can look or what else might be my problem. I did not hear anything like a solenoid clicking and I'm hoping for a simple breaker reset. Thanks