Jump to content

Search the Community

Showing results for tags 'xs-mp1620w'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Contests!!
    • Contests!!
    • Polls!!
  • Chaparral Boats Forum
    • Boat Talk
    • Dock Talk
    • Newbies
    • Info Center
  • Regional Forums
    • Midwest U.S.
    • Northeast U.S.
    • South Central U.S.
    • Southeastern U.S.
    • West Coast U.S.
    • Northwest U.S.
    • Rocky Mountain Region U.S.
    • Eastern Canada
    • Western Canada
    • International Boating
  • Suggestions & Comments
    • Site Suggestions & Comments
  • Gulf Coast

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. Hey gang, So we have 8 speakers on L'atatude (and three sub-woofers). The eight speakers are all Sony XS-MP1620w. One of the speakers just below the radar arch on the port side has crapped out. I actually didn't know all this time what model speakers we had (they were installed by the original owner) until I removed the speaker from the side wall. This is when I found they are Sony XS-MP1620w. I went online today to see if I could find the exact same speaker to replace this blown one with, and boy was I surprised when I started reading the reviews. Turns out these speakers are great when
×
×
  • Create New...