Jump to content

Recommended Posts

Just now, Onefastaudi said:

Thanks, I'll do the bilge thing next time out

On our outdrive equipped 350, we have a battery storage area over top of the forward aft bilge that had a clogged drain hole to the lower bilge that had some standing water that wasn't draining to the bilge.  Not sure how things are configured in the v-drive version, look for areas that may be pooling water and not draining under normal conditions.  

 

 

Share this post


Link to post
Share on other sites

what does the light on bilge switch mean when it comes on, does it mean the auto pump is running?

Share this post


Link to post
Share on other sites

I started installing the Fusion MS-AV750 Yesterday which went very smooth so far!  I went with the same wiring technique as Mrcody's post above, which was very easy. The stereo is very impressive!  I eventually want to upgrade my speakers and add more speaker zones.  

I also purchased the Fusion Wired Remote to replace the old remote at the Helm.  I also want to connect my Raymarine MFD for more control.  Both the Remote and MFD connect to the stereo via NMEA-2000 cable. 

Help!  Has anyone run a cable from the stereo/breaker panel to the helm or cockpit speakers on a Signature 350?  Do I have to remove panels?  Snake a wire? Drill through the closet?  It all seams very tight.  Any Advice would be greatly appreciated?

Thanks!

Share this post


Link to post
Share on other sites

Hello there fellow 350 owners..JC here all the way from sunny Singapore !! ..Yep that's right half way round the world from u fellow chaps.

I've been lurking on and  off the past few years (trolling for answers to a million problems) and finally decided to join the forum. Have a Sig 350 built 2007 that came with diesel's (cummins mercruiser es320) with bravo 3 drives (26p props) and have had her since 2012 so she's 10 this year. Even after 5 years I'm still learning about this beast and the problems she can give but like all boaters it gives me great pleasure when all is working well. Contrary to what Ive read on other forums, the engines itself have been working fine and good so far. Initially I had cooling problems as previosu owner kept the boat in the water. Since Ive got it its been drystacked but salt build up etc has blocked the cooling and ive had io all cleaned n replaced and boat run max 32-33kts at 3900rpm. Is this slow ? what do u guys do ?  :D

Couple of things I've done so far..upgraded or changed

1. replaced old raymarine chartplotter to e95 hybrid touch screen/radar n sonar

2. installed Flo scan meters - shows the rpm much better that the analog gauges and flow rate

3. additional house battery

4. Custom made T-Top boat shade - one of the best things I'd ever done as the arch doesn't provide much shade when we're anchored. Its typically hot n sunny down here

Current mods to be done..

1 . Change the whole steering - Im sick n tired of the current steering system which uses the pulley to drive the power assisted pump. Keeps bursting regularly (altho Ive changed the pulleys, the service guys here suck and I always need to tell them to ensure its aligned and they don't do that or forget so i've given up. I'm planning to get seastar. Anyone here has done the same or changed their sterering to full hydraulic ? or can advise what hydraulic steering cylinder fits in to replace the current mercruiser steering cylinder ?

2. Change the props to a better one..current 26p is 3 blade but that will be later on.

Cheers

Jeremy

Share this post


Link to post
Share on other sites

I haven't been very active lately, but i thought i'll check in and show everybody what we did on the boat this past spring.

Stainless steel cup holders with blue LED lights. Stainless steel cup holders at the helm. Stainless steel cup holders on a removable console. New stainless steel steering wheel, new VHF240 to replace the 215, remote activated LED light at the helm, custom fitted cockpit cover with vent. Custom made, by myself, drawer to hold the TV above the sink. aft table refinished with shiny clearcoat. I wish I could show you it all but apparently there is a limit to the Kb download.

chap1.jpg

Share this post


Link to post
Share on other sites

Just purchased a 2009 350 Signature with the hard top. Waiting patiently for her arrival. I'm a little late to this thread but love the information!

IMG_1293.JPG

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×