Jump to content
Sign in to follow this  
98Sig29

Acceleration Issue

Recommended Posts

Hello All, 

I have a single 7.4 V8 Mercruiser on my Signature 29.  The last few trips out, with 6 people on the boat, I can't seem to reach plane.  Full throttle position gets me to 3800 RPMs and about 14 knots. If I move all bodies to the front of the boat I can eventually reach plane but I don't think a boat this size should have this much trouble with a relatively light load.  If I'm by myself or with one person seems to plane quicker and will accelerate to 27-28 knots. 

Has anyone had a similar issue? 

Thanks, 


Ben

Share this post


Link to post
Share on other sites
2 hours ago, Mi3sons said:

How are the props looking?

A couple of small dings but not enough I would think that to be the problem.  When I pull it out at the end of the season I'll get a better look. 

 

Share this post


Link to post
Share on other sites
4 minutes ago, 98Sig29 said:

A couple of small dings but not enough I would think that to be the problem.  When I pull it out at the end of the season I'll get a better look. 

 

On the out drive lower gear case where the prop collar enters the out drive, is there corrosion in that area where exhaust gasses can sneak out and ventilate the prop? I've needed to do epoxy repairs on a few drives that were slip stored, and not properly painted and the boat just refused to get on plane, even though the bottom was clean. Could always be an engine issue but it is hard to know without doing some testing and learning some of your ride's maintenance history.  W

Share this post


Link to post
Share on other sites
13 hours ago, Wingnut said:

On the out drive lower gear case where the prop collar enters the out drive, is there corrosion in that area where exhaust gasses can sneak out and ventilate the prop? I've needed to do epoxy repairs on a few drives that were slip stored, and not properly painted and the boat just refused to get on plane, even though the bottom was clean. Could always be an engine issue but it is hard to know without doing some testing and learning some of your ride's maintenance history.  W

it is probably a combination of factors(props/tune-up/plugs/ect...). Put it in the wqter immediately after purxhase. After the season i'll get it to a mechanic for a full check-up! Thx Wingnut!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...