rprahl

1994 75hp Mariner boggs down

2 posts in this topic

I have a 1994 Mariner 75hp 3 cylinder OB and it will run for a while just fine but then when you go to restart it you have to keep pushing in the key to keep the motor running. Even after a short warm up. When the key is pushed in the idle with pick up 2k and run fine for a little while then it will start to bogg down again.

Share this post


Link to post
Share on other sites
16 hours ago, rprahl said:

I have a 1994 Mariner 75hp 3 cylinder OB and it will run for a while just fine but then when you go to restart it you have to keep pushing in the key to keep the motor running. Even after a short warm up. When the key is pushed in the idle with pick up 2k and run fine for a little while then it will start to bogg down again.

Could be lots of things. Lack of fuel, clogged up carbs, etc. Those engines had issues with the black stators that would give you symptom just like you stated. Would have it taken for an Ohms test. To replace the stator, it requires pulling the flywheel. (when performing a stator test, engine should be cold, not just previously run)

New red style stators are quite robust. The old black ones not so much...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now