Jump to content

Recommended Posts

Ok guys I feel somewhat stupid in this trouble shooting issue i have been having with my speedometer. I have tried the drill bit in the pitot hole and cleaned debris out only to find out that my speedometer still didn't work. Just yesterday when I was cleaning the boat after having it out on the water I noticed a small diameter hose that was hanging down from the lower unit. Well you guessed it looks like somehow my pickup tube split in half not sure if it's age related the tube seems pliable still never the less is split in half. How hard is it to replace and does anyone have a video on this process to see how involved it is going to be. I have a Alpha One Gen 2 outdrive. Thanks in Advance.

IMG_1820 (1).JPG

Link to post
Share on other sites

Image result for pitot tube couplingthe correct way is to purchase a new tube and run it through - purchase this barbed coupler and connect the broken ends until a complete replacement is done in the winter ($2) repair w/ a bit of gorilla tape to hold into place

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...