PY

Westerbeke Generator not loading

6 posts in this topic

 

I have a 3KW Westerbeke gasoline Gen set and it won't allow a/c to run.  The gen set runs great and will run my other appliances and holds a steady 60 he and 120 volts, but when the a/c compressor tries to start the voltage will drop off and the a/c will shut down and alarms on low voltage.    The a/c runs fine on shore power.  I have changed the plugs, and fuel filter.  Neither were dirty or worn.  Its acting ike the generator should speed up to keep the voltage up but does not.  Any suggestions on what I can do besides shop it of course. 

Share this post


Link to post
Share on other sites

Could be a weak compressor starting capacitor on the AC condensing unit.

Share this post


Link to post
Share on other sites
1 hour ago, PY said:

 

I have a 3KW Westerbeke gasoline Gen set and it won't allow a/c to run.  The gen set runs great and will run my other appliances and holds a steady 60 he and 120 volts, but when the a/c compressor tries to start the voltage will drop off and the a/c will shut down and alarms on low voltage.    The a/c runs fine on shore power.  I have changed the plugs, and fuel filter.  Neither were dirty or worn.  Its acting ike the generator should speed up to keep the voltage up but does not.  Any suggestions on what I can do besides shop it of course. 

Your saying that the genset is not throttling up as it should? It has worked in the past? 

Share this post


Link to post
Share on other sites
1 hour ago, PY said:

 

I have a 3KW Westerbeke gasoline Gen set and it won't allow a/c to run.  The gen set runs great and will run my other appliances and holds a steady 60 he and 120 volts, but when the a/c compressor tries to start the voltage will drop off and the a/c will shut down and alarms on low voltage.    The a/c runs fine on shore power.  I have changed the plugs, and fuel filter.  Neither were dirty or worn.  Its acting ike the generator should speed up to keep the voltage up but does not.  Any suggestions on what I can do besides shop it of course. 

Do you have the water heater on?  The 3KW Westerbeke is a very under-sized genset for our boats.  I have the same thing.  I cannot run A/C while water heater is on.  Try isolating all other AC equipment and see if the generator will power ONLY the A/C.

I hate this generator.  Piece of garbage.

Share this post


Link to post
Share on other sites
On ‎10‎/‎6‎/‎2017 at 2:39 PM, TexasPilot71 said:

Do you have the water heater on?  The 3KW Westerbeke is a very under-sized genset for our boats.  I have the same thing.  I cannot run A/C while water heater is on.  Try isolating all other AC equipment and see if the generator will power ONLY the A/C.

I hate this generator.  Piece of garbage.

I have tried switching everything off except the A/C.  It started one time and I thought I had solved the problem.  We closed the cabin and made it to our swim hole and then I discovered the A/C had went down and the panel was giving me the low voltage alarm.  I never could get it to start again.  Once we made it back to the dock and plugged into shore power the A/C started right up.   I tired to speed the generator with the governor myself but it was to no avail. 

Share this post


Link to post
Share on other sites

Have the in-rush initial start current tested with an amp-probe and if it is with specs, check the high pressure side Freon pressure at rest, and if it's ok, replace the start capactor. If it's too high, then the expansion valve may need to be replaced.  They are cheap. I'll assume you have checked all the wire terminations for torque and corrosion. Does it fail on initial start after being at rest for an extended period, or only upon repeated re-start after use.  W

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now