Jump to content
Sign in to follow this  
Painless

2001 196 SSi

Recommended Posts

Hello everyone, I have a question about my 01 196 SSi, I have owned this boat for a little over a year and we have only had it on the water a few times.  I noticed that my hydraulic trim fluid is leakin out of my bilge.  I have pretty much narrowed it down to the hoses or a bad manifold. Anyone had any experience with this?  My mechanic thinks it's the hoses and is saying he will need to pull the engine to repair.  Pretty sure he is right but wanted to get opinions here as well.  Thanks for any input.

 

Blake

Share this post


Link to post
Share on other sites

Also wanted to add that I have changed out the trim reservoir to the newer style so I know it is not leaking out of that.

 

Thanks

Share this post


Link to post
Share on other sites

When you say "leaking out of the bilge", is it oil sheen on the water that you are noticing or can you see fluid in the bilge that is actually finding its way into the water?

 

I have experience with the seals on my trim cylinders failing which showed up as an oily sheen on the surface of the water behind the boat.  I replaced them rather than rebuild but there are people who've taken on the job of rebuilding them using kits available online.

 

Sean

Share this post


Link to post
Share on other sites

No it is definitely coming from inside the boat but I can't see any of it in the bilge of the boat just leaking out of drain plug.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×