Jump to content

Recommended Posts

Changed out an impeller for a friend. Alpha 1 Gen 2. put back together fired it up and found lube leaking. Its coming out a small weep hole right where the shift shaft where it comes through the upper case..I havent pulled the upper off yet but is there a seal that might have gotten damaged? Heres a vid I found of the weep hole..differance is I'm getting lube coming out and not water

Share this post


Link to post
Share on other sites

Your Alpha split case lower unit has a small o-ring between the case half's, which seals off the lube oil passage port. The port allows gear oil to flow between the upper and lower case half's, and it would seem that it may have fallen out when you split the case half's to service your water pump. It measures about 3/8" in diameter, and can be held in place with a dab of grease during re-assembly.   W

Share this post


Link to post
Share on other sites
1 hour ago, Wingnut said:

Your Alpha split case lower unit has a small o-ring between the case half's, which seals off the lube oil passage port. The port allows gear oil to flow between the upper and lower case half's, and it would seem that it may have fallen out when you split the case half's to service your water pump. It measures about 3/8" in diameter, and can be held in place with a dab of grease during re-assembly.   W

+1.  This is what i would go after, especially if you know it wasn't leaking prior to the service.

Share this post


Link to post
Share on other sites

I pulled it again amd looked at the o ring..it was still in place and didnt appear to be leaking there.. when  i reinstall ill be careful to make sure it doesnt move. i did bind the shift linkage slightly when i started to bolt it together. didnt know if there is a seal i might have push out when that happened.

Share this post


Link to post
Share on other sites

Pressure test before install, then you can easily see where the leak is.

Share this post


Link to post
Share on other sites

i did bind the shift linkage slightly when i started to bolt it together.

 

Well you could have cracked the shift shaft  plate that has a seal in it but that would be leaking from the lower unit, If you see oil coming from above that  like from the upper part of the shift shaft then its leaking into the bellow

Share this post


Link to post
Share on other sites
2 hours ago, Bt Doctur said:

i did bind the shift linkage slightly when i started to bolt it together.

 

Well you could have cracked the shift shaft  plate that has a seal in it but that would be leaking from the lower unit, If you see oil coming from above that  like from the upper part of the shift shaft then its leaking into the bellow

Out drive shift shaft seal won't leak gear oil into the bellow, it will leak externally.  

 

This is also why i don't like the idea of using the nuts to seat the drive or a "mer-kick" as a member of another forum refers to it.  If alignment is proper, the drive should seat with little effort of your hands, if not, something is wrong.

Share this post


Link to post
Share on other sites
6 minutes ago, Dennis A said:

Out drive shift shaft seal won't leak gear oil into the bellow, it will leak externally.  

+1. Mine came out of the two little holes at the leading edge of the outdrive just above the cavitation plate.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×