Jump to content
Bar3

Voltage issue

Recommended Posts

When I test my battery I get a good 12.5 but as soon as I start the outboard motor, the meter goes blank, unable to read any output. 

Share this post


Link to post
Share on other sites

Bring the battery to any of the Autozone or similar placea, they will load test it for free.

Share this post


Link to post
Share on other sites
On 8/10/2018 at 5:18 PM, Bar3 said:

When I test my battery I get a good 12.5 but as soon as I start the outboard motor, the meter goes blank, unable to read any output. 

You should be getting more like 13.5 volts. Thats why your getting the reading.

Share this post


Link to post
Share on other sites

12.5V is waay too low. Fully charged should be 13.7 I believe. 

Share this post


Link to post
Share on other sites

12.9 would be a fully charged lead acid battery.  12.5 volts is about 73% charged.  Open circuit voltage, nothing drawing.  .7 volts would be if the engine was running and the alternator was charging the battery.

Share this post


Link to post
Share on other sites

Recharged & rested for about 1 hour.  All my new Lead Acids are close to being 12.7 volts. They drop about to 12 .5 when first cranked.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×