Jump to content
Jose Luis

Helm switches have no light

Recommended Posts

Hello Chaparral mates

I have bought last year a 2008 236 SSX Chaparral. Everything working fine and very happy with the boat. But I can't make the rocker switches on the helm to light. I have change the dimmer and switch module, but still not working.

 

Anything else to check?

 

Thanks in advance for your help

Share this post


Link to post
Share on other sites

Are your Nav lights on?

 

But to be honest about, underway at night its not a big deal. 

Share this post


Link to post
Share on other sites

Are the 2 new parts good ?  I have bought brand new rejects plenty of times.   A more accurate check of the parts is required.  Are all the light bulbs / LEDs  burned out ?

A defective battery charger / alternator can bun them out. Been there with another persons boat lights.

Share this post


Link to post
Share on other sites
On 5/10/2019 at 2:17 PM, Jose Luis said:

Hello Chaparral mates

I have bought last year a 2008 236 SSX Chaparral. Everything working fine and very happy with the boat. But I can't make the rocker switches on the helm to light. I have change the dimmer and switch module, but still not working.

 

Anything else to check?

 

Thanks in advance for your help

Does the light side of the circuit have power? The dimmer leads are easiest to check.

Share this post


Link to post
Share on other sites
12 hours ago, Curt said:

Does the light side of the circuit have power? The dimmer leads are easiest to check.

Did you check the fuse?"  Denny.

Share this post


Link to post
Share on other sites

I have checked the fuses, there is current coming, the bulbs are o.k.

I've seen this is a recurrent issue on Chaparral boats, am I right?

Share this post


Link to post
Share on other sites

If the lights to all the switches aren't working the wiring is wrong.  Re-check your connections and make sure it's properly grounded.

Share this post


Link to post
Share on other sites

The lights are all in parallel wiring.  Do you have a DC VOLTAGE METER ?  Can you test EACH SIDE of a couple of lights ? 

WE need to know if BOTH SIDES of a light socket has + 12 vdc ?

Or if both sides have 0 vdc ?

OR if only 1 side has 12 vdc?

I think the bulbs have a LOOSE OR DISCONNECTED MAIN WIRE.  The + or -  feed wire.  WE will find the problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×