Jump to content
Challenger2458

Replace the battery 203 vortex 2015

Recommended Posts

I just removed the battery and fully charged it. When I put it back in all my games work but when I turn the key on nothing happens.its in natural. What do I need to do or reset. 

Share this post


Link to post
Share on other sites

Did you leave any other cables off? Is this a Vovlo or Merc engine? What about the lanyard, is that in place?

Share this post


Link to post
Share on other sites

I have the same boat and have taken my battery out numerous times and reconnected the cables with no issues.  Most of the obvious items were mentioned (boat in neutral, lanyard connected, battery switch in on position, cables hooked up properly - correct + / - wires, cables securely tightened, etc.) .  Perhaps you can recheck the charge of the battery with a volt meter to assure that it was fully charged.  Sorry for not being able to be of more help.

Share this post


Link to post
Share on other sites

There is a very high resistance connection in 1 of those 2 big cable connections. Corroded wire internally..... can not be seen.  That Will cause your condition. severe corrosion an the battery posts or cable clamp surfaces. Remove the cables. Inspect the inside of the clamp surfaces. Lots of white crystals around the posts ? Water has boiled out of the battery.  Have yo always added water befor the level dropped out of sight ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...