Jump to content
yogi799

Clarion stereo problem - restarting every 5 seconds

Recommended Posts

so finally my clarion stereo has began to act up big time, i have the main unit and two "remotes", one in the helm and one in the transom.

in the past i've had a problem where if i turned up the volume on the remote (by holding volume up button), it would sometimes not stop and go up to max causing us to go deaf for a moment before the unit could be turned off.

but now the whole system started restarting every 5 seconds.

someone on the searay forum said 1st step in troubleshooting is to remove the head unit and disconnect both remotes from it in the back, to see if they are causing the problem. does anyone have a better idea of some experience with that POS system? i say POS because it acted up from the very beginning, while it was probably still under warranty (that max volume thing). but now it's too much, needs to be fixed. i don't care for the remotes, i just want the sound to work, even with just the head unit, so i hope it ain't broken.

** ok, so i found some older threads and they too recommend unplugging the remotes first. 

is it hard to remove the head unit? do i pry it out or what? mine is above the helm storage compartment, located on the side of the helm, in the walkway basically.

Share this post


Link to post
Share on other sites

Yes, I would disconnect one remote at a time to see.  There has to be a way to remove the head unit without prying it out. I would download the manual to see if a key or some sort of release tool is needed. My old Sony head unit, you needed there key which has flat to be inserted on the sides to pull it out. 

Share this post


Link to post
Share on other sites
6 hours ago, yogi799 said:

so finally my clarion stereo has began to act up big time, i have the main unit and two "remotes", one in the helm and one in the transom.

in the past i've had a problem where if i turned up the volume on the remote (by holding volume up button), it would sometimes not stop and go up to max causing us to go deaf for a moment before the unit could be turned off.

but now the whole system started restarting every 5 seconds.

someone on the searay forum said 1st step in troubleshooting is to remove the head unit and disconnect both remotes from it in the back, to see if they are causing the problem. does anyone have a better idea of some experience with that POS system? i say POS because it acted up from the very beginning, while it was probably still under warranty (that max volume thing). but now it's too much, needs to be fixed. i don't care for the remotes, i just want the sound to work, even with just the head unit, so i hope it ain't broken.

** ok, so i found some older threads and they too recommend unplugging the remotes first. 

is it hard to remove the head unit? do i pry it out or what? mine is above the helm storage compartment, located on the side of the helm, in the walkway basically.

If it's the larger Clarion unit that the face drops down when you open it, there are rubber covers on each side that you pull off that hide the four screws holding the unit in. Remove the screws and it should pull straight out. If it's a bad remote, you can also disconnect the remote at the remote end. They only have about a foot long pigtail on them then the connect to an extension cable back to the head unit where there is a Y cable. I'd be shocked if your issue is the Y or extension cables 

Share this post


Link to post
Share on other sites

as a 2013 you probably have the cmd5 clarion?  If you don't like it and don't care about the remotes, just replace it with a new head unit.  

get a new unit that has blue tooth and control the music with your phone.  swapping out for a new one is not that involved if you are up for a small project.  

couple hundred dollars.  More in time and research.  

Share this post


Link to post
Share on other sites

Check your grounds and power wire for bad connections. Also like others have said disconnect the remotes and set if that helps. My helm remote did the volume thing also. I ended up replacing it. 
If all else fails the Clarion M608 is a direct replacement. Will work with your remotes and has all the cool new features. I scored a used one off EBay for $125 to replace my CMD8. 

Share this post


Link to post
Share on other sites

thanks guys, wow, great advice all around.

so turned out access to the back is extremely simple, you just put your head in the helm storage compartment and back of the radio is there, easily accessible. i had only one big connector for 2 wired remotes and i disconnected it... reconnected... and radio stopped restarting! whoa! so it must have been some short in the connector which was not touched in 7 years.  all good now, but great advice should the problem reoccur. thanks guys.

this is my unit btw

8d5d6cab016dbfdd4007703ab3322ac7.jpg

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...