Jump to content
Sign in to follow this  
mcarney5

Newbie - help needed to solve stalling issue

Recommended Posts

Help please. I just purchased a 2007 215 SSI and having 2 issues - engine (Mercruiser 5.0L carb aplpha 1) consistently stalls under 800RPM. And always stalls when I am trying to go through neutral to change gears. This makes docking a real difficult and anxious experience. I also notice that the engine will go from 800RPM to 1800RPM with a slight touch of the shift lever - not smooth at all. And sometimes when I am idling at 1200 RPM, it jumps up 1400 RPM, then back down, then back up - kinda like revving without me touching anything.  I thought maybe it was old gas as it had about 10G from last year so I added 35G 89octane.I have run it for 6 hours so far and no change, actually getting worse.  I also sprayed the carb with carb cleaner. This did not help. 

The second issue is changing gears as it takes a while for the transmission to kick in - almost 45 degrees from neutral. This makes changing gears time consuming and add the stalling, very difficult to maneuver. It has a tune up last year with new cap and plugs.

Are there some things I can do to stop the stalling? I plan to clean the air box/flame arrestor. Anything else that I can clean, lube, etc.? Thanks in advance. 

Share this post


Link to post
Share on other sites
4 minutes ago, mcarney5 said:

Help please. I just purchased a 2007 215 SSI and having 2 issues - engine (Mercruiser 5.0L carb) consistently stalls under 800RPM. And always stalls when I am trying to go through neutral to change gears. This makes docking a real difficult and anxious experience. I also notice that the engine will go from 800RPM to 1800RPM with a slight touch of the shift lever - not smooth at all. And sometimes when I am idling at 1200 RPM, it jumps up 1400 RPM, then back down, then back up - kinda like revving without me touching anything.  I thought maybe it was old gas as it had about 10G from last year so I added 35G 89octane.I have run it for 6 hours so far and no change, actually getting worse.  I also sprayed the carb with carb cleaner. This did not help. 

The second issue is changing gears as it takes a while for the transmission to kick in - almost 45 degrees from neutral. This makes changing gears time consuming and add the stalling, very difficult to maneuver. It has a tune up last year with new cap and plugs.

Are there some things I can do to stop the stalling? I plan to clean the air box/flame arrestor. Anything else that I can clean, lube, etc.? Thanks in advance. 

Hard to get a real picture by remote control, but I suspect you may have a failing idle enrichment solenoid.  Also, is your drive an Alpha or a Bravo? The shifting and stalling could be the shift interrupter switch if it's an Alpha equipped boat.   W

Share this post


Link to post
Share on other sites

Does it stall when shifting from reverse to neutral, forward to neutral, or both? Also, send me a pm with a valid e-mail address and I'll get some documentation to you that will help with troubleshooting.  W

Share this post


Link to post
Share on other sites
14 hours ago, mcarney5 said:

it stalls in both directions

I sent you the engine trouble shooting tables, and I still believe it is the idle enrichment solenoid. You can bench test those following the procedures in the manual.  W

Share this post


Link to post
Share on other sites

Hi - after some research, it could be either the solenoid or the lower shift cable. Since the shifting is getting worse, I would point to that as one of the issues. I am going to pull it out and bring it for service. I'll let you know the results. thank you

Share this post


Link to post
Share on other sites
52 minutes ago, mcarney5 said:

Hi - after some research, it could be either the solenoid or the lower shift cable. Since the shifting is getting worse, I would point to that as one of the issues. I am going to pull it out and bring it for service. I'll let you know the results. thank you

The shift interrupter switch (solenoid as you referred to it) only actuates when you shift from reverse to neutral. That's why I asked if it happens in both directions. Does not explain why you are having a stalling issue when you shift into forward.  W

Share this post


Link to post
Share on other sites

Does replacing the lower shift cable require pulling out the boat or is this something that can be done while in the water! Thx

Share this post


Link to post
Share on other sites
23 minutes ago, mcarney5 said:

Does replacing the lower shift cable require pulling out the boat or is this something that can be done while in the water! Thx

The out drive needs to be removed, so gimbel bearing, bellows, and u-joints inspection along with engine alignment check are also prudent during the process. W

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...