Jump to content
Sign in to follow this  
Winning

Poor acceleration

Recommended Posts

Hi all, 

Lately I’ve noticed poor acceleration and the oil pressure drops to almost 0. The oil is a bit on the high mark on the dipstick. 

I removed the fuel pumps and cleaned out their screens. They were filthy. I also dumped the contents of the fuel filter water separator. There was some water in there. 

I pulled the fuel tank pickup tube and the fittings and tube itself look great. It did not have a screen on it. 
 

other than idling sometimes and pulling skiers around the boat runs smoothly and is powerful. 

 

so you know what’s going on? Any advice or has this happened to anyone else? 
 

Thanks.
Jay

Share this post


Link to post
Share on other sites

I would be worried about the oil pressure.  Also, did the oil level go up with use?  If so, is it milky?  Oil level doesn’t go up unless water is added.  Check the oil pressure with a different gauge to eliminate engine mechanical failure before proceeding with anything else.  Engines tend to fail pretty quickly with 0 oil pressure.

Share this post


Link to post
Share on other sites

A engine that can make oil ???  With 0 oil pressure.  that much stuff in all the filters.  Has  not been taken care of correctly.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...