Jump to content
Sign in to follow this  
CARMELHILL

My neutral button on my Quicksilver

Recommended Posts

My neutral button on my Quicksilver 3000 shifter sticks. I'll take the cable off the engine, push i tback and forth, until it releases. Then after reattaching it I can get maybe 3 or 4 throws of the throttle while pushing the neutral in and out, until it sticks again.

Does anyuone know where I can find the manual for this shifter so I can take it apart? My friend thinks it needs lubricationm inside the throttle handle. I only see on screw on the inside of the lever.

Share this post


Link to post
Share on other sites

Could be the button itself that is broken. Push the button in, and place the handle to wide open throttle. Remove the button by then inserting a flat headed screw driver behind the button, and pulling out. There was a MerCruiser service bulletin about some of the shifters from that era failing. MerCruiser SB 96-13. Have no idea if your controller falls under this recall. Also, taking the shifter apart is often futile. A MerCruiser dealer should have the manual you need, manual # 90-814705R2.

I recomend replacing the entire shifter and cables with MerCruiser Gen II panel shifter and Mercury Gen II Platinum control cables. Take a look at the 2008 Chaparral's for the style of MerCruiser shifter. The handle is easier to use compared to 2007 and older models. Will make a huge difference in shifting and throttling quality. The Commander 3000 shifters can be fun to line up properly where the bezel plate meets the shift box; if not properly aligned, then the shifting/throttle quality sucks.

In short, I do not like the Commander 3000 or Commander 3000 classic shifters compared with the new Gen II units. This is the kind of scenario we run into every summer, and changing the shifter and cables is the best remedy, but is not cheap.

Chris

Gordon Marine

1000 Islands

Chris

Share this post


Link to post
Share on other sites

I had a similar problem with mine. The dealer replaced the whole unit, indicating that sub-components weren't available. I don't recall the exact price but, it wasn't cheap.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×