Sign in to follow this  
Followers 0
JimmyG

Greetings,For some reason my engine

6 posts in this topic

Greetings,

For some reason my engine hatch won't open. I've checked the breaker and battery and everything is good. Not so much as a peep out of it when I push the switch. I removed the screw off access point at the rear of the boat and think I can feel the pull pin. The pin seems really hard to pull and I don't want to break something; wasn't sure if I need to do something special or just pull it really hard. Can anyone please offer some pointers and maybe a reason why my hatch lift won't work. Thanks

Share this post


Link to post
Share on other sites

Did you find the small push breaker for the lift motor under your helm? If so check for 12vdc at the switch OUTPUT when you push the switch with a DVM. if there is 12vdc that was 0vdc before you pushed the switch then the issue is the lift motor or wiring from switch to this motor. The only way to test is to pull that pin (should take a tight pull but not superman....). Then you can check the 12vdc getting to the motor. If it is then replace the lift motor.

Share this post


Link to post
Share on other sites

I can't help you there, but want to piggy back on the question. Does anyone know if on a sunesta 264 the engine hatch will open without the batteries installed? I assume so but the hatch seems very heavy.

Share this post


Link to post
Share on other sites
duh, I guess I should let you all know it's a 2009 Sig 280....

On the 330, you are in a whole heap of trouble if the lift doesn't work. The first thing I would do on a 2009 280, after checking breaker and battery switch, would be to dial the dealer and tell him to get his self out to the boat to fix it! :pirate:

Here is a LINK to a previous thread on a 330 that had problems. It may help.

Share this post


Link to post
Share on other sites

Oops - i missed the fact that it is a 2009.... First make sure your batteries are all turned ON (this has been the issue from another new boater). Then if that doesn't fix it call the dealer - let him figure it out.

As for the 264 - if it is big and heavy that means it is POWER as in you don't lift it...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0